Results 1 to 4 of 4
  1. #1
    Join Date
    Oct 2011
    Posts
    20

    Default Romance Rewards Login

    Help! My husband and I returned from our first trip to CTI 2 weeks ago. I signed up for Romance Rewards before we left, or so I thought. When I did the pre-check in online before we left, I signed in using my email and password. It showed that we were at the First Love level.

    We are already planning our next trip to Couples (CSA here we come!) so I wanted to login to Romance Rewards to make sure that we got credit for our trip earlier this month. However when I try to login it brings me to the page to fill out all the information again (username, password, address, etc.). I did, just in case and it says my email is already in use. Tried checking in with our guest number and it takes me to the same page with the form to fill out. What am I doing wrong?!

    Any help would be appreciated!

  2. #2
    Join Date
    Jun 2009
    Posts
    1,424

    Default

    Quote Originally Posted by cti5712 View Post
    . . . Tried checking in with our guest number and it takes me to the same page with the form to fill out. What am I doing wrong?!
    You're not alone! I've been having this identical problem for months. If I enter incorrect information, the system tells me that there's an error, but if I enter in the correct information, the system just clears out the log-in form and leave me with the blank form to fill out again.

    I'm assuming that they're aware of the problem and will fix it eventually.
    Pamela
    I know everything, and I'm always right (just ask my husband).

  3. #3
    Join Date
    Jul 2009
    Posts
    988

    Default

    I don't know about you, but I was having the same problem as well, more then once. Turns out, my log in is different for the Romance Rewards, then it is for the message boards.

    I have a document saved in my library that carries user ID and passwords so now I go there first to remind myself what it is for Romance Rewards. Being an old fart, I have to look at it every time.

  4. #4
    Join Date
    Oct 2011
    Posts
    20

    Default

    Glad to see I'm not alone. I wonder if there is anyone to contact to get my correct login information or to notify of the problem? I'll have to look into this or if anyone else figures it out in the meantime please let us know. Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •